InsightIDR Dashboard and Reporting Intermittency

Incident Report for Rapid7

Resolved

This incident has been resolved.
Posted May 06, 2025 - 21:30 UTC

Monitoring

The issue affecting InsightIDR dashboards and reporting has been mitigated. Functionality has been restored, and systems are now operating normally. We are monitoring to ensure full stability.
Posted May 06, 2025 - 20:05 UTC

Investigating

We’re currently investigating an issue causing intermittent unavailability of InsightIDR dashboards and home pages. Front-end reporting may also be impacted. Our engineering team is working to identify the root cause and restore full functionality.
Posted May 06, 2025 - 17:00 UTC
This incident affected: InsightIDR (US1) (User Interface), InsightIDR (CA) (User Interface), and InsightIDR (US2) (User Interface).